4982 sujets

Le Bar du forum

Hello!

Depuis la mise à jour de Yosemite, j'ai un soucis, il semble avec la version de ruby.

Si je veux utilise compass j'ai le message suivant :
/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/dependency.rb:296:in `to_specs': Could not find 'compass' (>= 0) among 0 total gem(s) (Gem::LoadError)
	from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/dependency.rb:307:in `to_spec'
	from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_gem.rb:47:in `gem'
	from /usr/bin/compass:22:in `<main>'


et si je fais :
ruby -v

il me renvoit ça :
ruby 1.9.3p327 (2012-11-10 revision 37606) [x86_64-darwin12.3.0]


Est-ce que quelqu'un aurait une solution svp ? Smiley decu
Merci d'avance!

EDIT :
Après diverses manip, voici ce que j'ai si je fais :
compass w

il m'affiche :
/usr/bin/compass: /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby: bad interpreter: Too many levels of symbolic links

Modifié par exootia (18 Dec 2014 - 18:04)