27818 sujets

CSS et mise en forme, CSS3

Bonjour,
J'ai un problème avec le thème de mon site wordpress qui est Colibri (thème builder en version gratuite).
J'ai créé un portfolio avec des overlay sur les images, mais quand on passe la souris sur chacune de ces dernières l'effet de transparence avec la couleur reste au lieu de disparaitre au bout d'une seconde. Je précise que je n'ai ce problème que sur certains ordinateurs, dont celui qui me sert à développer le site (ce qui est un peu gênant), et que sur d'autres tout fonctionne correctement. J'ai cherché un peu avec l'inspecteur mais pour le moment je ne trouve pas de solution sachant que les pc où cela fonctionne possèdent le même navigateur et le même OS (windows 10 familial 64 bits). Merci de votre aide.

mon site : gregoireherbin.fr
Modifié par melozy (23 Nov 2020 - 16:42)
Merci mais j'ai déjà essayé sans succès. Cela fait la même chose avec tous les navigateurs sur mon ordinateur d'ailleurs.
Modérateur
Bonjour,

Sur Mac OS, quelque soit le navigateur :
1) si on arrive sur une image, l'effet de transparence reste tant qu'on est sur l'image
2) si on passe d'une image 1 à une image 2 en survolant rapidement une image 3, l'effet de transparence reste sur l'image 3 pendant 1s environ
3) je n'ai trouvé aucune image où l'effet de transparence disparait au bout d'un certain temps (si on reste sur l'image)
4) je n'avais rien compris à la question lors de ton premier post. Du coup, si tu veux mon avis, ce n'est pas très important du point de vue de l'expérience utilisateur
5) par contre, s'il y a effectivement des cas où la transparence disparait au bout d'une seconde alors qu'on est encore sur l'image, et que c'est l'effet souhaité, c'est clair qu'il faudrait trouver pourquoi. Mais est-ce bien le cas ? as-tu testé toi-même ?

Amicalement,
Modifié par parsimonhi (23 Nov 2020 - 20:42)
Bonjour,

Merci pour tes observations, mais apparemment d'après ce que tu me décris tout semble fonctionner sur ton mac, c'est le comportement normal. En fait sur mon ordi, et sur un autre que j'ai chez mes parents, l'effet de transparence reste une fois que l'on a survolé l'image, si bien que si tu survoles toutes les images tout reste bleu, l'effet ne disparait pas.
Sur Chrome et Edge j'ai le message suivant :"JQMIGRATE: Migrate is installed, version 1.4.1"
Sur Mozilla par contre j ai des erreurs : "Content Security Policy: La source « http: » présente dans script-src a été ignorée : « strict-dynamic » a été spécifié" est la phrase qui revient le plus. J'ai été me renseigné sur internet et apparemment il y a un souci avec le strict-dynamic, car internet explorer ne le supporte pas et pour une fois l'affichage du portfolio fonctionne presque correctement (je n'ai pas la rotation sur la première image) avec ce navigateur. Par contre cela n'explique pas pourquoi cela fonctionne sur d'autres ordinateurs avec Chrome et pas le mien.
Modérateur
Bonjour,

Les erreurs que tu vois ne sont pas reliées à ton problème a priori.

Comme je n'arrive pas à reproduire ton problème, et que ta page contient énormément de codes, impossible de faire le diagnostic.

1) Cet effet, il est de base dans colibri ? ou bien c'est un truc que t'as bricoler toi-même ?

2) Tu devrais essayer de faire une page où il n'y a que ton portfolio et rien d'autre, avec le minimum de fichiers inclus. Peut-être qu'on arrivera ensuite à voir d'où vient le problème.

Amicalement,
Modifié par parsimonhi (24 Nov 2020 - 18:58)
Bonjour,

1) Oui l'effet sur les images fait bien parti du thème de colibri.
2) J'ai rajouté une page avec juste un portfolio (portfolio test).
Modérateur
Bonjour,

J'ai regardé "portfolio test", j'ai encore divisé par 10 la taille du code qui s'y trouvait (j'en suis à environ 140 lignes), mais il en reste encore beaucoup dans des fichiers annexes qui sont de plus minimifiés. L'effet qui bogue est malheureusement effectué via du code javascript peu lisible éparpillés dans plusieurs fichiers. Et comme je ne reproduis toujours pas l'erreur, je pense qu'on est condamné à ne jamais trouver d'où vient ce problème sauf coup de bol.

Amicalement,
Bonsoir,

Je te remercie d'avoir pris le temps de m'aider. Je suis en contact avec un développeur du thème donc j'ai encore un peu d'espoir, sinon je ferai avec pour le moment comme le problème n'apparait que sur 2 de mes pc.

Merci encore !

Bonne soirée

Grégoire