26744 sujets

CSS et mise en forme, CSS3

Bonjour j'ai un problème avec la balise display : inline.
Je m'explique voilà le code que j'ai mis par défaut pour les images.
img {
  display: block;
  max-width: 100%;
  height: auto;
}

Or, pour les images de la classe puce je souhaiterais que cela passe en display : inline j'ai donc mis le code suivant dans mon CSS.
.puce img {
  display: inline;
}


Normalement je suis en héritage pour toutes les balises images sauf pour celles de la classe "puce" qui devrait être en line alors que les autres sont en display block.
http://www.centrejaya.org/essais/spip.php?article157
Cela ne fonctionne pas peut-être aurais-je oublié quelque chose.

Je mets le lien de la page. Quand j'utilise l'outil de Firefox firebug je vois bien que pour les puces qui se retrouvent dans le corps du texte elles n'ont pas d'affectation inline !
J'espère être clair.
Est ce que quelqu'un aurait une petite idée.
Bonne année.
Philippe
Modifié par philippe974 (18 Jan 2019 - 17:21)
Bonjour,

Il me semble que dans ton code, la classe "puce" est affectée aux images en question et non à un contenant de ces images.

Du coup, le sélecteur à employer est img.puce (au lieu de .puce img).

Après, y a peut-être d'autres problèmes, mais déjà, corrige celui-là !

Amicalement,
C'est exactement ça. Si je comprends bien : tel que je l'avais mis ça ne pouvait s'appliquer qu'à un div avec la classe puce qui aurait contenu l'image.
Comme la classe puce ne s'applique qu'à l'image il faut mettre img.puce et effectivement ça fonctionne.
Merci
Modifié par philippe974 (18 Jan 2019 - 19:58)