26748 sujets

CSS et mise en forme, CSS3

Pages :
Bonjours,

Depuis hier soir, je bute sur ce problème:

Mon code CSS:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
	   "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
  <title>Programmation d&eacute;butant XHTML, CSS, JavaScript.</title>
  <meta http-equiv="Content-type" content="text/html; charset=UTF-8" />
  <meta name="author" lang="fr" content="Jean-Marie ">
  <link href="Index2.css" rel="StyleSheet" type="text/css" />
</head>
<body>
<div class="conteneur">
<div id="head1"><h1>Que j'aimerais savoir!</h1></div>
<div id="gauche">ronron</div>
<div id="droite">nnnnnnnnn</div>
<div id="centre">
<p>blabla</p>
<p>blabla</p>
etc....
</div>
</body>
</div>
</html>

Le résultat:

un vide
mon head
un vide
mes 3 colonnes

Je n'arrive pas à supprimer les vides avant et après le head.
J'essaie de joindre une copie d'écran, mais j'ai un panneau d'erreur !!!
Pris de cours, (je pars au travail) je retente ce soir, en attendant,
quequ'un a peut-être une idée ?

Merci
Modifié le 27 Nov 2004 - 02:09
Est-ce possible de placer ton code dans les balises appropriées [code ][/code ] (sans les espaces) ?
Attention aux balises croisées :


[#red]<body>[/#]
[#red]<div class="conteneur">[/#]
<div id="head1"><h1>Que j'aimerais savoir!</h1></div>
<div id="gauche">ronron</div>
<div id="droite">nnnnnnnnn</div>
<div id="centre">
<p>blabla</p>
<p>blabla</p>
etc....
</div>
[#red]</body>[/#]
[#red]</div>[/#]
c'est vrai, c'est un oubli, mais mais même sans, j'ai le même prob.

pardon de ne pas poursuivre maintenant, je dois absolument partir.

a ce soir !
Administrateur
J'ai enlevé les trop nombreux points d'exclamations présents dans le titre de ton sujet.
Fournis le CSS comme demandé également, STP.
Bonsoir tout le monde,

Oups! Haaa...! Ahlzeimer quand tu nous tiens....

En fait vous avez raison, c'est le code CSS que je voulais vous soumettre.

VOILA:

.conteneur { /* définition du bloc conteneur (parent du bloc body) */
	 background-color:#CCCCCC;
     margin-left: auto;
     margin-right: auto;
     width: 770px; /* largeur obligatoire pour être centré */
     text-align: center; /* on rétablit l'alignement normal du texte */
     }
     
body { /* définition du bloc body (enfant du bloc conteneur) */
background-color:#88b9de;
margin: 0px;/* sans marges, la page sera collée aux bords */
text-align: left;
font-family: verdana, arial, sans-serif; /* on définit la police de base dans la page */
font-size: 12px; /* on définit la taille de police de base dans la page */
}

#head1 {
background-color: #a7b4e6 ;
margin: 116px;
width: 770px;
height: 91px;
}

#gauche {
position: absolute; /* on place le bloc gauche à gauche en position absolue */
left: 116px; 
background-color: #88b9de ;
width: 150px;
height: 337px;
}

#centre {
background-color: #d8f2f4 ;
margin-left: 266px; /* on place le bloc centre par rapport à la largeur du bloc gauche */
width: 470px;
height: 337px;
text-align:justify;
}

#droite {
position: absolute; /* on place le bloc droit à droite en position absolue par rapport an bloc centre */
margin-left: 470px; 
background-color: #88b9de ;
width: 150px;
height: 337px;
}

h1 {
margin-top: 20px;
color:blue;
text-align:center;
}


Milles excuses, mais je suis à la recherche du seul neurone qui me restait!
Je tente encore une fois de poster une prise d'écran de l'affichage que j'obtiend:


Apparement, ça marche toujours pas!!!!!!!!

Qu'un peut-il mexpliquer la manip ?

Merci Smiley help
Modifié le 26 Nov 2004 - 20:45
Modérateur
ATLONIA a écrit :
Je tente encore une fois de poster une prise d'écran de l'affichage que j'obtiend:


Apparement, ça marche toujours pas!!!!!!!!

Qu'un peut-il mexpliquer la manip ?

Merci Smiley help

Il faut cliquer sur le lien "Joindre une image" qui une ouvre une fenêtre pop-up comme ci dessous:

upload/128-01.gif

Tu sélectionnes sur ton disque dur l'image souhaitée (penser à uploader des images de largeur modeste pour que la lecture du forum reste facile), tu cliques sur envoyer.
Le pop-up doit t'indiquer que tu as réussi et tu es invité à valider ton image:
upload/128-02.gif

Verdict je poste et je vois si les infos que je donne fonctionnent Smiley cligne
Igor a écrit :

Il faut cliquer sur le lien "Joindre une image" qui une ouvre une fenêtre pop-up comme ci dessous:

upload/128-01.gif

Tu sélectionnes sur ton disque dur l'image souhaitée (penser à uploader des images de largeur modeste pour que la lecture du forum reste facile), tu cliques sur envoyer.
Le pop-up doit t'indiquer que tu as réussi et tu es invité à valider ton image:
upload/128-02.gif


Verdict je poste et je vois si les infos que je donne fonctionnent Smiley cligne


Merci igor, mais encore deux essais infructueux, je comprend pas!
Ce que Stephan te disais, c'était pour insérer une image sur le forum.

En utilisant la syntaxe BBcode [ img]url_de_ton_image (sans les espace) et Igor disait qu'en utilisant le lien "joindre une image" sous la zone de réponse, tu pouvais le faire aussi Smiley cligne
Très simple, le lien que je t'ai donné explique les fonctionnalités de ce forum. On peut y lire comment intégrer une image à notre message, et plus encore.

Voilà ! Smiley cligne
D:\Documents perso\Mes images\EssaiPageWeb.psd

Comme ça, c'est bon ?


Ben non !!!!!!!
Modifié le 26 Nov 2004 - 21:26
Ahh oui mais là tu as utilisé la syntaxe BBcode pour insérer une image en ligne.

Pour joindre une image en local il faut utiliser le lien "Joindre une image" sous la zone de saisie de texte. Tu vas chercher ton image et ça roule.
Stephan a écrit :
Très simple, le lien que je t'ai donné explique les fonctionnalités de ce forum. On peut y lire comment intégrer une image à notre message, et plus encore.

Voilà ! Smiley cligne


OK Stephan, merci, je vais bosser dessus.
Pages :