Salut,

J'ai un problème avec blogger ou j'ai installé dewplayer playlist.
Le lecteur s'affiche, mais dans la bar de défilement il y a le message xml error.
Les morceaux ne s'affiche pas non plus!!!

Je vous mets mon code:

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="240" height="200" id="dewplayer" type="application/x-shockwave-flash">
  <param name="allowScriptAccess" value="sameDomain" />
  <param name="movie" value="http://www.isolated.ch/browns/dewplayer-playlist.swf?xml=http://www.isolated.ch/browns/playslist.xml&amp;showtime=true"/>
  <param name="quality" value="high" />
  <param name="bgcolor" value="#fffffff" />
  <param name="wmode" value="transparent" />
  <embed src="http://www.isolated.ch/browns/dewplayer-playlist.swf xml=http://www.isolated.ch/browns/playslist.xml&amp;showtime=true" wmode="transparent" quality="high" bgcolor="#ffffff" width="240" height="200" name="dewplayer" allowscriptaccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" >
</embed></object>


Est-ce que l'erreur viendrais de là ou de ma page xml?
Modifié par 6l20 (06 Oct 2011 - 11:04)
Modérateur
Bonjour,

Merci d'utilser les balises prévues à cet effet pour présenter vos codes sur le forum : bouton éditer, puis sélection de votre code et direction la colorisation syntaxique (nom de code : code)
dans votre cas.

La fonction recherche du forum, même si elle n'est pas parfaite, vous aurait apporté quelques éléments de réponse (au même titre que votre moteur de recherche préféré...)
Pour terminer sur le chapitre "bonnes pratiques, la FAQ ou le forum de votre moteur de blog favori, pourraient également vous apporter une aide précieuse.

Il n'y a a priori pas de fichier XML à l'adresse indiquée (erreur 404) difficile de dire s'il contient des erreurs...
Sinon, de mémoire, Blogger n'est pas un hébergeur, il vous faudrait donc externaliser vos fichiers et éventuellement le lecteur (à vérifier...)
Vérifier également votre code grâce aux différentes pistes données plus haut Smiley cligne
Bonne continuation.
Bonjour,

J'ai trouvé une erreur de syntaxe dans mon code, il y a les morceaux qui se sont afficher dans le player mais je ne peux pas les jouer!

Je fais mes test sur IE, sur Firefox le player ne s'affiche même pas!

Je n'y comprend plus rien!!
Modérateur
tantrum a écrit :

oui j'ai vérifier mon chemin d'accès de mon fichier xml.
Si tu prends l'adresse ou est hébérger mon fichier xml, tu le vois sans problème.

La bonne adresse :
http://www.isolated.ch/browns/playlist.xml
Ton code :
http://www.isolated.ch/browns/playslist.xml

Reste à vérifier en hébergeant ailleurs tes fichiers (mp3 et .swf) si ce n'est pas déjà fait...
Essayer ce type de code tout simple :

<object type="application/x-shockwave-flash" data="http://www.isolated.ch/browns/dewplayer-playlist.swf" width="240" height="200" id="dewplayer" name="dewplayer">
	<param name="wmode" value="transparent" />
	<param name="movie" value="http://www.isolated.ch/browns/dewplayer-playlist.swf" />
	<param name="flashvars" value="showtime=true&xml=http://www.isolated.ch/browns/playlist.xml" />
</object>

Nous fournir l'adresse de la page où est placé le tout ? Smiley cligne
J'ai fais la correction merci.

J'ai fais le test avec le code simplifier, ça n'a rien changé sur IE par contre sur Firefox le player est visible, mais il ne fonctionne pas, à la diffèrence de IE je peux appuyer sur play ou les morceaux mais rien ne fonctionne.
Modérateur
Les fichiers mp3 se trouvent bien à cette adresse http://www.isolated.ch/browns/mp3 ?
Comme stipulé dans la FAQ :
a écrit :

Compatibilité MP3
Utilisez des fichiers MP3 encodés à 44.1 Khz sinon la lecture se fera en accéléré. Aucun autre format (AAC, WMA, OGG, ASX, M3U, PLS etc) ne pourra être supporté ni développé.
Pas de souci à ce niveau ?
Modérateur
tantrum a écrit :
Merci pour ton aide mais pour finir je suis passé par un autre player soundclouds.

Oui, j'avais vu...dommage, car le player fonctionne aussi sur Blogger Smiley cligne

L'essentiel étant certainement que tu sois parvenu à tes fins Smiley jap

Un petit [résolu] placé dans le titre en éditant ton premier post serait le bienvenu Smiley cligne

ps : petit oubli de ma part, la musique est sympa Smiley smile
Salut,

Je ressors le sujet parce que j'ai sensiblement le même problème et que le dewplayer me plaît bien.
Donc j'ai essayé différents codes:

D'abords celui fournis dans le .ZIP:

    <object type="application/x-shockwave-flash" data="http://swindled.free.fr/fg/dewplayer-vol.swf" width="200" height="20" id="dewplayer" name="dewplayer">
    <param name="movie" value="http://swindled.free.fr/fg/dewplayer-vol.swf" />
    <param name="flashvars" value="mp3=http://swindled.free.fr/fg/interviews/tagada@tamtam.mp3" />
    <param name="wmode" value="transparent" />
    </object>



Ensuite un autre trouvé sur internet:
<object type="application/x-shockwave-flash" data="http://swindled.free.fr/fg/dewplayer-vol.swf?son=http://swindled.free.fr/fg/interviews/tagada@tamtam.mp3" width="180" height="20"> <param name="movie" value="http://swindled.free.fr/fg/dewplayer-vol.swf?son=http://swindled.free.fr/fg/interviews/tagada@tamtam.mp3" /> </object>


Et enfin celui que proposé dans ce topic (modifié pour mes besoins).
<object type="application/x-shockwave-flash" data="http://swindled.free.fr/fg/dewplayer-bubble-vol.swf" width="240" height="200" id="dewplayer" name="dewplayer">
<param name="wmode" value="transparent" />
<param name="movie" value="http://swindled.free.fr/fg/dewplayer-bubble-vol.swf" />
<param name="flashvars" value="showtime=true&mp3=http://swindled.free.fr/fg/interviews/tagada@tamtam.mp3" />
</object>


Donc l'adresse du blog c'est: http://fadedgecko.blogspot.com
l'hébergement du player c'est: http://swindled.free.fr/fg/dewplayer-bubble-vol.swf
enfin celle du son c'est: http://swindled.free.fr/fg/interviews/tagada@tamtam.mp3

Voilà