Pages :
Salut,
J'ai des soucis a cause des BOM qui me rendent malade et font que IE refuse d'afficher correctement mon site.
J'utilise Notepad++ et je trouve que leur systeme n'est pas clair du tout: comment concretement sauvegarder un fichier en UTF-8 sans BOM?
D'autre part, j'ai entendu qu'on peut regler ce probleme du BOM cote serveur.
Si mon serveur est Linux, comment je fais?
Merci d'avance
Salut,

IE déconne parceque la BOM ajoute des caractères avant le Doctype, ce qui le fait passer en mode Quirks, comme le ferait le prologue XML.

Pour passer en UTF-8 sans BOM avec notepad++ (version 3.5 pour la mienne), c'est très simple :

* Encoder en ANSI + cocher la dernière ligne "encoder en UTF-8 (sans BOM)" dans le menu "format".

Et ça roule Smiley cligne
CreeAll a écrit :
OUi c'est ça mais attention l'opération est à refaire a chaque ré-ouverture du fichier !


Non, à chaque création de fichier, mais pas d'ouverture, moi ça marche parfaitement. (enfin, j'ai testé avec l'option "garder les onglets de la session précédentes et les rouvrir au lancement", ça vient peut être de là... ?)

++
CreeAll a écrit :
OUi c'est ça mais attention l'opération est à refaire a chaque ré-ouverture du fichier !


<modération>On peut le formuler sans être agressif</modération>
SI un fichier est écrit en tel encodage, il le ré-ouvre dans l'encodage correct. C'est détecter automatiquement

rien à voir avec les onglets concervés
Modifié par Laurent Denis (08 Sep 2006 - 11:53)
nORKy a écrit :


SI un fichier est écrit en tel encodage, il le ré-ouvre dans l'encodage correct. C'est détecter automatiquement

rien à voir avec les onglets concervés


Hola, doucement hein, je parlais des onglets conservés à l'ouverture parceque c'est ce que je fais, j'allais pas m'avancer sur un autre cas sans avoir testé même si j'étais à peu près sûr que ça fonctionnait aussi.
cela ne marche pas pour l'option "utf-8 sans Bom", mais oui un fichier en Ansi s'ouvre en ainsi bein évidement.
Je ne travaille pas sur 1 ou 2 fichiers ni sur un seul projet donc je ne suis pas dans le cas de l'ouverture par session precedente enregistrée.
j'enregistre en ANSI utf-8 sans Bom, je ferme, je relance, je suis en ansi classic, je dois donc remettre le "sans Bom" manuellement à chaque réouverture du dit fichier.
Si il existe un moyen pour que l'attribue "sans Bom" soit reconnu je veux bien une solution. Mais pour le moment ce n'est pas le cas.

Bonne soirée.
Modifié par CreeAll (10 Sep 2006 - 08:48)
CreeAll a écrit :
cela ne marche pas pour l'option "utf-8 sans Bom", mais oui un fichier en Ansi s'ouvre en ainsi bein évidement.
Je ne travaille pas sur 1 ou 2 fichiers ni sur un seul projet donc je ne suis pas dans le cas de l'ouverture par session precedente enregistrée.
j'enregistre en ANSI utf-8 sans Bom, je ferme, je relance, je suis en ansi classic, je dois donc remettre le "sans Bom" manuellement à chaque réouverture du dit fichier.
Si il existe un moyen pour que l'attribue "sans Bom" soit reconnu je veux bien une solution. Mais pour le moment ce n'est pas le cas.

Bonne soirée.

C'est vraiment bizarre, je n'ai pas du tout ce comportement de mon côté Smiley ohwell

As tu regardé ce qu'il en était sur le site de notepad++ ?
++
Moi ce que je ne comprend pas c'est pourquoi encoder de l'utf-8 en ANSI ?
ANSI n'est t-il pas un organisme, celui qui a sortie l'iso d'ailleurs ?
Modifié par korigan (14 Sep 2006 - 15:25)
CreeAll a écrit :
sous Notpad2 tout est plus simple.

J'aime aussi beaucoup Notepad2 et le conseille de tout coeur Smiley smile
chez moi aussi lorsque j'ouvre un fichier enregistré en ANSI + UTF sans BOM la cache "UTF sans BOM" a disparu et je dois la recocher.

j'ai essayé Notepad2 et effectivement il n'a pas ce comportement par contre il a un gros problème ... il n'a pas d'onglet ... et moi je bosse souvent avec plus de 10 fichiers en meme temps donc c'est pas vraiment un programme qui me permettra de travailler efficacement.
Hm, pour ma part j'utilise Ultraedit32 v 10.10 et je me confronte au meme probleme, sans que la mm solution soit applicable =) Quelqu'un sait ?
Florent V. a écrit :
À tout hasard, écumer les préférences du logiciel ?


J'ai bien sur regardé avant de poster Smiley cligne
Il y a bien une partie "save/load/conversion mais rien qui traite explicitement de BOM ou de Byte-Order Mark
À lire les forums d'UltraEdit, ça semble être assez prise de tête à configurer (du moins avant les versions 11-12 du logiciel). Il y aurait peut-être une modification d'un fichier .ini de configuration, mais pas sûr que ça marche.

Un résultat de recherche (en anglais) :
http://www.ultraedit.com/index.php?name=Forums&file=viewtopic&t=3511&highlight=bom

Bon, au moins j'aurais appris qu'il ne vaut mieux pas que je m'intéresse à UltraEdit... Smiley rolleyes
(... qui est peut-être très bien par ailleurs, mais les manipulations savantes à faire pour obtenir une gestion correcte des encodages, très peu pour moi... sur ce plan, Komodo Edit est assez sympathique, d'ailleurs.)
Modifié par Florent V. (07 Jun 2007 - 12:47)
Oui j'ai trouvé la mm page que toi, mais devant l'aspect "bricolage" de la manip et mon niveau d'anglais défaillant, j'ai préféré venir demander si quelqu'un en savait un peu plus long ici =)

Merci Florent.
Pages :