1448 sujets

Web Mobile et responsive web design

Bonjour, j'ai utilisé la balise viewport pour l'adaptation d'une (vieille) page en html. j'ai utilisé ceci :
<meta http-equiv="X-UA-Compatible" content="IE=edge"/>
<meta name="viewport" content="width=device-width, initial-scale=1"/>
dans le head.

Cela a fonctionné mais mes images apparaissaient dans un ordre différent que la page affichée sur pc. J'ai remis de l'ordre dans le code (après le </head>) mais depuis cela ne fonctionne plus.

J'ai essayé le css viewport à la place, le redimensionnement fonctionne mais je n'ai plus les liens sur la page.

Voili, une idée ?
Oui, je m'en doute, mais j'ai des kilos de css et de html derrière malgré le tri que je viens de faire.

Qu'est ce qui pourrait empêcher cette balise d'agir ?
Modérateur
Bonjour,

Peterparker a écrit :

Qu'est ce qui pourrait empêcher cette balise d'agir ?
Rien !

Néanmoins parmi le kilo de css il doit y avoir des propriétés qui agissent contre votre bon vouloir.

Si c'est le cas, cela revient à chercher une aiguille dans une meule de foin et donc une seule solution: le débogage.

Pour ce faire commentez tout ce qui concerne l'affichage, la présentation, bref tout ce qui touche de près ou de loin à vos images dans le css puis, dé-commentez une par une les lignes en contrôlant l'affichage jusqu'à tomber sur le bloc qui joue à mixer la présentation des dites images.

A ce stade vous aurez mis le doigt sur ce qui pose problème.

Ensuite soit vous trouver à résoudre le soucis tout seul comme un grand sinon n'hésitez pas à revenir ici bas en postant le résultat de vos trouvailles.

Quand on aura une vision claire du problème on pourra très certainement intervenir.


Bon courage et attention, les aiguilles ça pique ! Smiley cligne
Modifié par Greg_Lumiere (12 Apr 2018 - 08:36)
Greg_Lumiere a écrit :


Pour ce faire commentez tout ce qui concerne l'affichage, la présentation, bref tout ce qui touche de près ou de loin à vos images dans le css puis, dé-commentez une par une les lignes en contrôlant l'affichage jusqu'à tomber sur le bloc qui joue à mixer la présentation des dites images.
Smiley cligne


Pour cela, tu peux passer par l'inspecteur d'élément, plus rapide pour tester.
Alors, j'ai fait du ménage (un peu) dans dreamweaver en utilisant l'inspecteur et en erreurs à la validation, je n'ai que ceci :

An exception occurred! Type:NetAccessorException, Message:Could not connect to the socket for URL 'http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd' Smiley xml

et des problème de compatibilité avec les middle et alt (je n'en ai pas sur toutes mes images) avec explorer 6 et macintosh 5 (< Smiley eek )