7713 sujets

Développement web côté serveur, CMS

Hello

Je suis désespéré....

deux jours que j'essaye de cabler mon projet Symfony 3 (installer sous WAMP avec php 7.0.27) avec ma base SQLSERVER. Impossible..

J'essaye donc tous les drivers possibles (lié a sqlserv quand meme)


    dbal:
        driver : pdo_sqlsrv

Résultat = could not find driver
J'ai pourtant bien installé pdo_sqlserver dll dans le bon répertoire ext/ de php.
php_sqlsrv_7_nts_x64.dll
php_pdo_sqlsrv_7_nts_x64.dll

j'ai également essayé driver : php_sqlsrv_7_nts_x64

    dbal:
        driver : sqlsrv

Résultat = Attempted to call function "sqlsrv_configure" from namespace "Doctrine\DBAL\Driver\SQLSrv".
Pourtant dans Doctrine\DBAL\Driver\SQLSrv j'ai bien la class Driver.php qui est créer avec symfony au début... j'ai beau essayé de mettre
driver_class : Doctrine\DBAL\Driver\SQLSrv\Driver 

C'est le même résultat

Si j'essaye un autre driver que eux : j'ai un message clair :
exemple avec pdo_odbc :
The given 'driver' pdo_odbc is unknown, Doctrine currently supports only the following drivers: pdo_mysql, pdo_sqlite, pdo_pgsql, pdo_oci, oci8, ibm_db2, pdo_sqlsrv, mysqli, drizzle_pdo_mysql, sqlanywhere, sqlsrv


Voila, je suis complètement bloqué...
Avec Symfony 2 j'utilisé MSSQLBUNDLE (car j'étais sur serveur linux) mais maintenant c'est sensé être PLUS FACILE car je suis une version plus récente ET sur du windows (symfony) to windows (sql server)...

Je ne trouve aucune info dessus, j'ai beaucoup cherché sur l'internet et je trouve que des brides sur des forum de 2015

J'ai testé cela et ça ne marche pas.
En Français ici aussi, pareil, rien ne fonctionne (très peu d'infos)
J'ai testé ça également, mais pour la version 7 de php, rien ne fonctionne
Et puis ça, pareil, ne fonctionne pas.

Enfin bref...
Je vais peut être essayé d'installer DOCKER et gérer ça avec lui.. peut être aurais-je plus de change...