5079 sujets

Sémantique web et HTML

Bonjour j’ai un soucis avec la balise vidéo sur certains navigateurs au lieu d’afficher la première image de l’an vidéo c’est un carré blanc à la place j’ai vraiment besoin d’aide
Oui j’ai déjà regardé mais sur pc j’ai aucun problème mais avec les mobile que sa corce avec les vidéo présent sur la page au lieu que la première image de la vidéo s’affiche c’est un carré blanc qui est la
Bonjour,
une liste précise des navigateurs qui lisent tes vidéos et ceux qui ne les lisent pas serait bienvenue. En attendant, il faut savoir que la série de i quelque chose (Apple) ne lit nativement que les formats .m4v, .mp4 et .mov. Ou alors il faut installer une application sur l'appareil, ce qui n'est plus de la responsabilité du développeur... Certains appareils bloquent toute lecture s'ils ne rencontrent pas l'un de ces formats en tête de liste, même si le bon format est proposé dans la suite de la liste.
Dans l'ensemble, il est prudent de proposer plusieurs formats (mpeg, mp4, etc.). La balise video du html5 est parfaite pour faire ça.
Un très bon convertisseur, sous Linux, c'est Transmageddon, qui produit des vidéos fluides :
http://www.linuxrising.org/
Une page blanche qui s'affiche à l'ouverture d'une vidéo est typique de l'absence de cette vidéo ou d'un format non reconnu. C'est la même chose pour le son.
Bon courage.
Bonjour merci pour vos réponse mais c’est pas un problème de format car les navigateurs sont capable de lire la vidéo mais c’est l’affichage de la vidéo qui laisse à désirer j’ai un carré blanc à la place de la première image de la vidéo
Sosa a écrit :
Bonjour merci pour vos réponse mais c’est pas un problème de format car les navigateurs sont capable de lire la vidéo mais c’est l’affichage de la vidéo qui laisse à désirer j’ai un carré blanc à la place de la première image de la vidéo


Lire la vidéo, afficher la vidéo, on ne comprend pas bien la différence. Un carré blanc à la place de la première image ? Et les suivantes 1/24 ème de seconde plus tard ?
Y-a-t-il un lien, ce serait plus facile. Avec le code, parce que là, on discute un peu dans le vide.
Pour proposer une vidéo, on peut utiliser un lien ou une image cliquable avec usemap. Si c'est cette image cliquable qui n'apparaît pas, il faut voir du côté de la balise img.
Salut. Le problème est simple Tu demande de lire une vidéo sans sonner l’adresse de cette vidéo puis tu fermes la balise <video>...

En claire voici un exemple qui marche :

<video width="400" height="222" controls="" src="http://www.amneville-regie.com/img_base/webtv/astuce-5-cannele-sale-bon.mp4">Christophe Le Lay nous montre comment réaliser des minis cannelés salés.</video>.

see : https://bluestacks.vip/ , https://textnow.vip/ , https://downloader.vip/vpn/
Modifié par nateliv (15 Dec 2018 - 11:22)