5024 sujets

Sémantique web et HTML

Bonsoir,
Voilà mon souci, j'ai un site web construit avec un template html/css.
Je souhaite intégrer un texte défilant (avec vTicker de jQuery).
Pour ce faire j'ai placer mon script dans un fichier php. Celui-ci s'affiche correctement lorsque je l'ouvre dans mon navigateur.
Je fais une include de ce fichier sur la page de mon site web et la cela ne s'affiche pas correctement.
Je pense que c'est un problème de css ; j'ai déjà effectué quelques petites modifications mais sans vain.
De plus la div contenant l'id du script jQuery ajoute un grand espace avant mon contenu.

Voilà un extrait du code de la page de l'include:

<header id="masthead" class="ui page site-header" role="banner">
            <div class="topbar">
                <div class="container">
                    <div class="topbar_left fleft">
                            <?php include('inc/admin/informations.php') ?>
                    </div>


La page informations.php :

<div id="affichage_informations_admin">
        <ul>
            <li>Info 1</li>
            <li>Info 2</li>
            <li>Info 3</li>
            <li>Info4</li>
        </ul>

    </div>
    <script>
    $(function() {
    $('#affichage_informations_admin').vTicker();
    }); 
    </script>


Et un lien vers le fichier CSS:
https://www.rd3f.fr/assets/css/style.css

J'aimerais un petit coup de pouce s'il vous plait Smiley smile

Merci.
Soldat8889 a écrit :
Dans ton include, as-tu écrit un &lt;?php echo ...; ?&gt; ou &lt;?= ... ?&gt; ?
C'est ptet ça le problème


Même en ajoutant le code directement sur la page sans passer par une include, j'obtient le problème. Ce n'est donc pas un problème d'include.
Bonjour mstaudt,
Tu as des log dans la console de debug?
La javascript de vTicker et jquery sont bien déclarés dans le header?
aliasdmc a écrit :
Bonjour mstaudt,
Tu as des log dans la console de debug?
La javascript de vTicker et jquery sont bien déclarés dans le header?


Bonsoir,
Oui tout est bien déclaré, mon script fonctionne parfaitement quand j'ouvre la page dans mon navigateur sans passer par l'include.
Cela doit être un problème de css.