Bonjour,
Je suis un développeur débutant en WEB et j'ai un problème avec mon include en php, lorsque je fais une include :
 <?php include '../php/menudenavigation.php' ?>

j'ai une erreur sur mon navigateur qui me mets :
<!--<?php include '../php/menudenavigation.php' ?>-->

et qui ne me mets pas mon menu de navigation.
(J'utilise Apache HTTP Server pour ce site web)
Merci d'avance,
Burger King Kong
Modérateur
Bonjour,

Où as-tu testé ta page ? En local ou sur un serveur distant ?
La page contenant ce code est-elle en php (as-t-elle l'extension .php dans le nom de ton fichier) ?
Si tu testes en local (c'est à dire que le serveur web est installé sur ton ordinateur), l'adresse que tu as mis dans ton navigateur commence-t-elle bien par "http" ?

Amicalement,
Modérateur
Bonjour,

Tu fais comment pour lancer ta page ? (tu cliques où ? tu entres quoi au clavier ?)

Ta page est-elle bien dans un répertoire frère du répertoire "php" (c'est à dire que le répertoire "php" et le répertoire dans lequel tu as mis le code de ta page sont tous les deux dans un même répertoire) ?

Amicalement,
Pour lancer ma page,
Je vais sur mon navigateur et je tape : localhost
j'arrive ensuite sur ma page.

Et oui les deux répertoires sont frères.

Cordialement et en m'excusant du retard.
Modérateur
Bonjour,

Normalement, ça devrait marcher si la page qui contient le include() est bien elle aussi en php, et si elle est bien située dans un répertoire frère par rapport à l'endroit où se trouve le script menudenavigation.php.

Le problème est ailleurs.

Amicalement,
BurgerKingKong a écrit :
Bonjour,
Aprés de multiple essais j'ai enfin réussi a faire une include
votre aides a été trés précieuse
Cordialment.


salut, et du coup quel été le problème ?