Bonjour,

J'ai posté la semaine dernière un message dans le forum "Critique de vos sites: code et design" et les retours qu'on m'a fait m'ont bien aidé à corriger certains détails de mon site que je finalise.

Ces jours-ci, je teste mon site avec le plus de navigateurs possible pour repérer ses différents bugs. J'ai Linux, donc j'ai installé Wine afin de pouvoir tester mon site avec Safari. Or c'est une version pour Windows qui ne reconnaît pas GRID que j'ai utilisé... Le site ne ressemble plus à rien, la structure n'est pas prise en compte...

S'il vous plaît, est-ce quelqu'un ayant une version de Safari pour mac pourrait tester mon site et me dire s'il y a des anomalies ?

J'ai bien utilisé le site caniuse.com au fur et à mesure de la construction du site, mais cela ne remplace pas les essais réels et je n'ai pas accès à un mac pour le moment.

Voici l'adresse : https://www.lappartementdesequilibre.net/

D'avance, merci !
Laure
Modérateur
Bonjour,

Ton site semble très bien marcher sur MacOS (10.15.7) + Safari (14.0.1).

Ça ne sert à rien de tester Safari sous Windows. Personne ne l'utilise, et il n'est pas du tout représentatif de ce que fait Safari actuellement.

Amicalement,
Bonsoir,

Ok. Merci beaucoup. En effet, je n'ai réalisé qu'après coup que ce ne serait pas la version la plus répandue de Safari. Tant mieux si ça fonctionne bien Smiley sweatdrop

J'en profite pour poser une autre question, toujours sur la problématique de la compatibilité : j'ai testé mon site avec Opera et la vidéo de la page d'accueil ne s'affiche pas du tout, l'écran est noir et les contrôles inexistants, on ne peut pas non plus cliquer dessus. S'il te plaît, as-tu une idée de ce qui cause cela ?

Amicalement,
Laure
C'est Opera pour Linux (Lubuntu 20.04), la dernière version, téléchargée depuis le site officiel.
Modérateur
Bonjour,

Il manque les balises </body> et </html> à la fin de ton fichier html.

Je ne sais pas si c'est ça (je n'ai pas ce qu'il faut pour tester ça).

EDIT: j'aurais dû écrire "ce n'est surement pas ça, mais il faut corriger quand même" Smiley cligne

Amicalement,
Modifié par parsimonhi (18 Nov 2020 - 21:37)
Modérateur
Bonjour,

Peut-être que ta version d'opera ne peut pas lire les videos de type .mp4.

Sinon, je vois pas.

Amicalement,
Bien sûr ! (pour les balises fermantes) Smiley eek Je vais corriger ça. Merci beaucoup.

Je chercherai pour le problème de la vidéo.

Bien à toi,
Laure