Merci pour cette réponse.
Oui chaque liens à bien l'ancre en question
si je retire l'ancre, le lien fonctionne correctement, si je rajoute l'ancre, plus rien Smiley ohwell
runtime ??? (Je veux bien l'explication Smiley ohwell )

J utilise un framework cakephp

<?= $this->Html->link('ACCUEIL',['controller' =>'Pages','action'=>'index','#'=>'accueil'],['class'=>'nav-link active']);?>

Je sais pas si ça répond à ta question.
Cependant pour tester je l'ai rédigé en dur :

<a href="http://localhost/ajb/pages/index/#accueil">lien</a>

Même résultat
mais.... il faut pas de / avant une ancre.....

ton #accueil il est sur ta page index ? dans ce cas index#accueil et pas index/#acceuil
JENCAL a écrit :
mais.... il faut pas de / avant une ancre.....
ton #accueil il est sur ta page index ? dans ce cas index#accueil et pas index/#acceuil

J'ai failli répondre ca aussi mais quand je teste, Chrome m'en met un automatiquement et ca a pas l'air de le gener Smiley sweatdrop

urlien a écrit :

Cependant pour tester je l'ai rédigé en dur :

&lt;a href="http://localhost/ajb/pages/index/#accueil"&gt;lien&lt;/a&gt;

Même résultat

Donc même sur ta page contact l'url du lien c'est index#accueil ? ou ça devient contact#accueil ?



urlien a écrit :
runtime ??? (Je veux bien l'explication Smiley ohwell )

Construit / généré à la volée quoi, en php par exemple, exactement comme tu fais. Donc oui ca a bien répondu a ma question Smiley smile
oups, désolé, c'est une erreur en rédigeant le message sur le forum, il n'y a pas de "/" dans mon code...
En fait le lien est un lien de navigation, il ne change donc pas il est toujours de la forme :

<a href="http://localhost/ajb/pages/index#accueil">lien</a>

Modifié par urlien (11 Mar 2019 - 16:55)
Edit: désolé, j'ai dis une bêtise. De prime abord je pensais à une redirection htaccess. Je vais "revoir ma copie". Smiley sweatdrop
Modifié par Greg_Lumiere (12 Mar 2019 - 08:36)
J'vais tenter de mettre un lien ce soir vers le travail en cours...cela peut-être vous aidera...
Peut-être une utilisation de jquery pourrait-être à l'origine de ce malaise Smiley smile
Merci de votre investissement Smiley smile Smiley smile Smiley smile
urlien a écrit :
J'vais tenter de mettre un lien ce soir vers le travail en cours...cela peut-être vous aidera...

Oui ca pourrait aider !
Smiley smile


urlien a écrit :
Peut-être une utilisation de jquery pourrait-être à l'origine de ce malaise

Possible, à suivre.
Voici le travail en cours...
Alors lorsque vous êtes sur la page contact et que vous cliquez sur accueil /ajbstudio ou références..
Mercizatous
Modifié par urlien (14 Mar 2019 - 15:20)
Effectivement...

De mon côté la console me signale l'erreur suivante:
TypeError: $(...).offset(...) is undefined
[...]/ajbstudio/js/index.js:60
Salut,

Moi j'ai une erreur Js sur ce code là :

//Smooth scroll
	$("a").on('click', function(event) {

		if (this.hash !== "") {
			event.preventDefault();
			var hash = this.hash;
			$('html, body').animate({
			scrollTop: $(hash).offset().top
			}, 550, function(){
			window.location.hash = hash;
			});
		}
	});


index.js:60 Uncaught TypeError: Cannot read property 'top' of undefined


En gros il ne peut pas scroll jusqu'au hash de l'url vu qu'il n'est pas sur la même page.

Pourquoi ne pas avoir gardé le même système de navigation sur tout ton site ? C'est déroutant de changer de page juste pour contact (et apparemment c'est aussi déroutant pour ton code....)
Oui, en fait je voulais pas faire un onepage et j'aimai l'idée de la petite animation entre les pages que je n'aurai pu mettre en place en onepage...
Faut donc que je rajoute des conditions à ma fonction smooth scroll ou bien que je revois ma navigation...