4856 sujets

Le Bar du forum

Bonsoir à tous.
J'ai un petit souci avec jQuery : Sa rétrocompatibilité.

J'utilise sur mon site jquery-3.0.0 mais j'ai eu plusieurs problèmes avec des plugins que je trouvais sur le net. Tout part du plugin m-custom-scrollbar ( http://manos.malihu.gr/jquery-custom-content-scroller ) et lorsque je l'utilisait avec ma version de jquery, sa ne donnais pas mais par contre quand je mettais la version fourni avec l'archive zip (1.9.1) le problème etait resolu.
Le même problème s'est également posé avec swipe (utiliser pour les galeries photos) jusqu'à ce que j'ai fini par adopter la version 1.9.1 de jquery
Maintenant, lorsque je veut utilser le phugin datepicker, et cette fois ci, c'est jquery 1.6.2 qui est soliicité.

La question que je me pose donc est de savoir si jquery est retrocompatible.
Merci pour vous éclairage
Ça dépend des fonctions utilisees par le plugin, mais il y a de grandes chances que ces plugins soient cassés avec la dernière version. Maintenant, si ces plugins ne sont plus maintenus, il serait peut être temps de piocher ailleurs.
Bonjour et désolé pour le retard.

Merci Olivier C donc si je comprend bien le problème ne vient pas de jQuery mais des plug-in que j’utilise et qui sont obsolète.

Merci encore