8418 sujets

Développement web côté serveur, CMS

Bonsoir,
Je vais essayer d'être explicite. Mon problème est très simple, mais je n'ai pas de solution !
Dans mon site, j'utilise un base de données. Au début du développement, la bas était dans le dossier qui l'utilisait. Mais avec le temps et le nouveaux développements, j'ai besoin d'accéder à cette base depuis n'importe lequel de mes dossiers. Je l'ai donc placée à la racine (www).
Mais pour éviter les remontées d'escaliers à coup de '../../', y a-t-il un moyen de déclarer cette base d'une simple adresse ? Bon, je suis un vieux crouton, et sous MsDos, la commande cd \ remontait à la racine du disque. Ceci pour expliquer ce que je désire. Une commande qui me remonte à la racine de www, de façon à déclarer simplement /Labasa/labase.db
Merci si quelqu'un a une idée ou même une solution.
Cordialement.
Horace
Salut à tous,
J'ai trouvé une solution, qui n'est pas forcément la meilleure, mais qui fonctionne ! C'est le but !
J'ai mis ma base de données à la racine de ma carte SD dans la Framboise, en dehors de www. Et dans mes pages php, j'ai le code suivant :

	$datasetname='sqlite:/labase/labase.db';

et le système va bien cherche la base où elle est, c'est à dire à la racine, grâce à "/", peu importe l'endroit où je me trouve dans l'application. Simple et efficace !
Amitiés H.
Mais il y a une suite !
Ou bien je suis nul, ou alors il y a quelque chose qui m'échappe.
Dans le même répertoire 'labase' à la racine, j'ai mis un sous-répertoire 'documents' qui contient les différents document référencés dans la base.
Si j'atteins bien ma base avec :

	$datasetname='sqlite:/labase/labase.db';

(voir plus haut),
je n'arrive pas à atteindre les documents eux-même.

<img src='/labase/documents/21.11.25ACA01Lettre à Mme Jolivet.jpg' Width  = "980" Height = "4550" alt="Lettre Jolivet"/>

j'ai systématiquement l'affichage de "Lettre Jolivet".
D'où je déduis que mon adresse URL ne fonctionne pas.
J'ai vérifié plus qu'une fois les emplacements de /labase te /labase/documens !

Grand mystère !
Une idée ?? Une piste ??
Merci d'avance et cordiales salutations
H.
Modérateur
Salut,

Peut être tenter avec un nom de fichier plus simple (= sans espaces, sans accents, sans points... juste des lettres) ?

Une fois dans l'inspecteur de code, si tu survole ou fait un clic droit sur l'url de l'image et "afficher dans un nouvel onglet" tu devrais pouvoir voir l'url de l'image et voir l'image. Et s'il n'y a rien au bout c'est que ton chemin n'est pas bon.